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AmRRON Digital Net Macro Files 2022

Installation and Use

Introduction:

The files contained in this ZIP file were created to assist the new AmRRON
NCS in running oh of the AmRRON HF digital nets. The user should think of
the macro file to be similar to a printed net script that an NCS might use
when conducting a voice net. The macros allow you to say most of what
you might say during a voice net, but with the simple pressing of buttons
(macro buttons). The net script will contain many blanks that each NCS will
have to fill in before reading the script over the air. Macro tags are used to
“fill in the blanks” for the NCS.

Some of the blanks won’t change (or, at least not very often). For example,
your name, your call sign, or the name of the net you are conducting.
Other blanks could change from week to week. For example, the NWOTW,
The AmCON Level, the Net Traffic Listing, etc. Some of the blanks will be
filled in with information that you’ve entered into your FLDIGI configuration,
such as your name and call sign. Others will be filled in by information that
you’ll edit and save into the enclosed .txt files.

This document will help you install, configure, and use these files. It
contains the macro file itself, as well as several .txt files that you’ll need to
edit. You should need to edit about three files only once. You’ll need to
edit two nets prior to the start of each net, as part of your net preparation --
the NWOTW and the Net Traffic List. And finally, you’ll use the net
checkins .txt file throughout your net, saving changes as the net
progresses.

This document assumes that the user is a little familiar with FLDIGI macros
(or is at least willing to look up macro tags in the FLDIG documentation), is
using a Windows or Linux operating system, and has a basic knowledge of
moving, copying, and editing basic files.

Once the user has installed these files and has an understanding of how
they work, he or she is free to customize them in whatever manner best
suites his or her needs.

The standardized AmRRON macro set can be used for a variety of functions,
and include buttons for:
√ NCS
√ ANCS
√ Check-in button
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Installation:
First, let’s put the file HF_Practice_Net.mdf in the macro folder where it
belongs. The location will depend on which OS you’re using. See the file
path in the chart below:

*If using Linux, and you do not see a .fldigi folder in your home folder,
then in your computer’s home folder file listing, right click your mouse
and select ‘Show hidden folders’. That will display the ‘dot’ files (file
names beginning with a . dot).

Second, move the files in the MacroTxt subdirectory where it belongs.
Copy/paste the MacroTxt folder from your unzip location, to your
fldigi/macros folder. This will keep all your macros and related .txt files in
one place for easy management and backing up.

After doing so, the subdirectory ...fldigi/macros should contain:
AmCON_Level.txt
Checkin_Roster.txt
Net_Traffic_List.txt
NWOTW.txt

Configuration:
Let’s start by editing the text files. These are used to fill in the blanks in
our net script. Any and all characters contained in these text files will be
transmitted. This includes spaces and carriage returns.

The easiest way to access the .txt files is by opening up fldigi. In the upper
left-hand corner select File > Folders > Fldigi config... and open the
macros folder. You should see your macros and the MacroTxt folder. Open
the MacroTxt folder.

Be sure to select ‘Save’ after editing, and prior to transmitting. Changes
you’ve made will not transmit until you ‘Save’ the changes.

First, open up the AmCON_Level.txt, and ensure it contains the current
AmCON level. You can obtain it from AmRRON.com.

Second, open up the Checkin_Roster.txt, and delete the sample roster.
Add your name to the top, and the ANCS if/when you establish one.

Next, open up the Net_Traffic_List.txt, overwrite the sample traffic list with
the traffic you will be sending during your net, including the precedence
level.

Finally, update the Net Word of the Week in the NWOTW.txt file.

Windows Vista and later
versions (7, 8, & 10)

C:\Users\<username>\fldigi.files\macros\

Earlier Versions C:\Documents and Settings\<username>\fldigi.files\macros\

*Linux /home/<username>/.fldigi/macros
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Next, we will update the macro buttons themselves. The beauty of using
macros is that you only have to type what you need to say once.

Open your fldigi program.
In the upper left-hand corner, click on File > Macros > Open.
Select the HF_Practice_Net.mdf

Note the macro buttons on row two

To display subsequent rows of macro buttons, left click on the row #
To display the previous row, right click on the row #

Take the time to go through the macro buttons and become familiar with
them, and the function of each. Row One is the standard setup for fldigi,
with the exception of the far right button, where we have added a macro for
checking in to a net. You will need to edit the NWOTW.txt file so it
will transmit the current NWOTW.

You will need to edit the macro buttons so they reflect your specific net
information, and point to the correct .txt files to be transmitted.
To edit the macro buttons, right click on the macro button you wish to edit.

A macro editor window will open:

There is some text in the macro that you will need to edit. For example, in
the 5 Minute announcement:

QST QST QST AmRRON de <MYCALL> The (Add the name of your net here)
digital net will begin in 5 min.
We wud appreciate a clear freq at that time.

QST QST QST AmRRON de <MYCALL> The Mountain Region 80 meter
AmRRON digital net will begin in 5 min.
We wud appreciate a clear freq at that time.
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You will need to edit the text in the following macros:
5 MIN (net name)
START (net name, and sked info -- day(s), weeks, times, freq, mode, etc.)
SIGNOFF (net name)

You will also need to go through the macros and edit the file path in order to
point the macro to the appropriate .txt file for the text contents to be
transmitted.

For example, the newly downloaded AmRRON macro set contains SAMPLE
filepaths, so you know what .txt file should be there.

For example:

We are currently at: <FILE:/.../AmCON Level.txt>

On my (JJS) computer the line in my macro reads as:

...ntly at: </home/jjs/.fldigi/macros/macros/MacroTxt/AmCON_Level.txt>

To do this, highlight and delete the sample filepath in the macro. Leave
your curser there. On the right side there is a list of macro commands.
Scroll down about a quarter of the way until you see <FILE>. Select it and
then click the button (at the top) with the green arrow.

A navigation window will pop up, allowing you to navigate to the .txt file
location and select it. It will then become a permanent part of your macro
once you click Apply and Save the macro.

To save your macro in fldigi, go to File > Macros > Save
You should rename the macro file to reflect the net you normally run as NCS.
For example 80m_PTZ_Practice.mdf
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You can customize the macro and save under as many different names as
nets you participate in. If you run four different nets, you would have four
macros, each modified to fit that net, with the .mdf file named accordingly.

You will need to edit the file paths in several macro buttons:
Check IN
START
TRFC AFT
Chkins Call
Chkins ACK
FLMSG TFC
SIGNOFF
ANCS NetStart
ANCS Call4Chkns
ANCS Close

Don’t forget to hit Apply and then Save your macro.

You will know if you do not have the file path correct. For example:

You intended to transmitWe are currently at AmCON-4

But instead, you sent:
We are currently at ERROR: CANNOT OPEN FILE

Using the Macros

Testing:
Prior to running a net with these macros, you’ll want to go through them to
make sure they work, they point to the appropriate ‘File:’.
You can turn your radio (or Signalink) off so you don’t actually transmit.

Getting Ready:
Be prepared ahead of time. As soon as you get information related to the
net, update the .txt files in your Macros folder (NWOTW, AmCON level,
Traffic listing, etc.). Go through the files and folders to ensure everything
is current. Save the file and close it. You won’t need to edit this until the
next net cycle.

Check-Ins:
You’ll need to keep your Checkin_Roster.txt file open on your desktop while
you run the net. This is the file where you’ll log the check-ins as they come
in. It’s used to send an acknowledgement of check-ins in batch format.

Open up the Checkin_Roster.txt file. Overwrite everything that’s in there
with your call sign, your state, and “(NCS).” (Note, as an NCS, you count
yourself as a net check-in. This is standard practice.) Now, save the file;
but, leave it open on your desktop. You’ll be updating and saving the file
throughout the net as you take check-ins.
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If someone says they have traffic to send, you’ll note it there. It will remind
you to come back to him or her at the appropriate time to send his or her
traffic.
Remember to save the file frequently as you go. The macro will only
transmit what’s actually saved in the file.

FLMSG and FLAMP:
AmRRON nets must pass on any official traffic, such as the most current AIB
(AmRRON Intelligence Brief)
Have FLMSG and FLAMP running when you start your net.
If it is a regional or training net, you may like to have something prepared
that is relevant to the region (weather warnings/watches/advisories/etc.) or
the training topic.
Send FLMSG traffic first, so anyone with FLDIGI may see pertinent
information in plain text, even if they don’t have FLMSG or FLAMP.
Then send the traffic using FLAMP, compressed, for practice with FEC
(Forward Error Correction), and so operators may run a checksum file hash
program to authenticate the traffic as official (CheckSum hash for AIBs are
posted at AmRRON.com).

Running the Net:
Open up FLDIGI. Next, go to File>Macros>Open in the upper left-hand
portion of the FLDIGI screen.

Now, select the RollNet.mdf file. You should now be able to see the new
macro buttons on your screen.
If you can’t see all four rows of them, go to View>View/Hide 48 macros. You
should now be able to see all four rows of the macro buttons. I’ll go through
each button and explain how to use them.
The first row of buttons should be relatively self-explanatory. Right-click on
each button to see what each one does. Since I’ve never run a net that
hasn’t gone “off script,” I use these to help with basic, free-form
conversational work.
Second Row:
For the most part, the buttons follow the natural flow of the net, in order,
from left to right.
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NCS set of macros (all of row 2 and the first half of row 3)

Row 2

OPTIONAL: If you have time to give a 5 minute warning, it
announces that the net will begin in 5 minutes and requests a
clear frequency.
(Above the Start macro button) If you do not receive and
acknowledgment from your ANCS request in your 5 minute
warning, this sends another request for ANCS. If still no
response, continue with your net and ignore the ANCS dialogue
macro buttons until a station volunteers for the role.
This begins the net preamble. Also requests emergency or priority
traffic.
If you have a station step up to act as ANCS, this button is a
request for him to announce the net is under way, for stations who
may not copy you directly.
This lists the traffic you have for the net (as NCS).
The second part of the preamble. Gives NWOTW and establishes
expectations for conduct. Then, it gives an example of the check
in format and invites stations to check in.
This acknowledges all of your check ins, transmitting the contents
of your Checkin_Roster.txt file.
This button does not automatically transmit, allowing you to
copy/paste new checkins to acknowledge them without sending
the entire list each time. It will stop transmitting automatically.
Tells all stations to hold transmissions, and announces message
traffic will follow via FLMSG. Switches mode to MFSK32.
Announces that the net traffic will follow using FLAMP,
compressed. For stations to wait until you ask for block fill
requests.
Invites stations missing five or fewer missing blocks to send
requests.
Invites stations missing any number of missing blocks. Good if
you have a smaller net and ample time to fill a lot of missing blks.
Preparatory announcement that the mode will be changed back to
Contestia 4/250.

Row 3
Switches the mode to Contestia 4/250 and reminds operators to
adjust squelch if needed.
Request to ANCS to ask for check ins/relays

NCS asking if there are any other late/missed/relay check ins for
the net. (alternatively, you could run the macro,
which would transmit acknowledgments of all stations checked in)
Last Call for check ins before closing the net.

Announces the end of the net and requests ANCS to announce the
close of the net after your final sign off.
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ANCS set of macros (second half of row 3)

Offering to accept ANCS role in reply to NCS opening request

ANCS announces the start of the net to those who cannot copy
NCS, upon NCS’s request. Asks stations to stand by.
Requests check ins or relays from stations who have no copy on
NCS.
ANCS acknowledgment of stations copied which will be relayed to
NCS. ANCS should have his Checkin_Roster.txt open.
Relays to NCS the list in his Checkin_Roster.txt file.

Announces the close of the net after NCS has requested the ANCS
to do so.

Check In macro (far right end of macro Row 1)

This is for checking in to a net in the format requested by NCS.
It automatically turns TxID OFF prior to transmitting. The
operator will need to be sure to add the Net Word of the Week to
the NWOTW.txt file.

As you take check-ins, type the callsign and state in your Checkin_Roster.txt
file and save it. You can also note if they have traffic, or if they’ve been
relayed in. Remember that the macro will transmit only what is saved in
that text file. Just because you typed it there doesn’t mean that it has been
saved.
Once the net is finished, you can print the CK-IN.txt file or save it as
something else if you wish to keep a more permanent record.

I hope this macro file and its supporting .txt files are useful.

This document updated and revised from the original macro installation and
use guide created by the late, and greatly missed, [Code-Name] Bravo
Delta-01.

See you on the air!
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